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Schedule Plus 5.11.0 

Released 
February 2026 
 

What’s New 

Installation 
This release includes significant changes to how Schedule Plus is installed. 

By default, Schedule Plus now installs to one of the following locations, depending on your operating 

system: 

(32-bit Windows) C:\Program Files\Schneider Electric\Schedule Plus 

(64-bit Windows) C:\Program Files (x86)\Schneider Electric\Schedule Plus 

Project and template files are now respectively stored in: 

Documents\Schedule Plus\Projects 

Documents\Schedule Plus\Templates 

    Any project or template files stored in the Projects and Templates sub-folders of the existing 

Schedule Plus installation will be migrated by the installer to the new locations shown above as part 

of installing this release. 

    Existing files stored in the new Projects and Templates folders shown above, that have the same 

name as the project or template files being migrated, will be overwritten without warning. 

    It is strongly recommended that you create a backup of any existing project and template files 
prior to proceeding with the installation. 

Once any existing data is migrated, the existing version of Schedule Plus will be uninstalled prior to 
the installation of this version. Moving forward, all future versions of Schedule Plus (5.11.0 and 
above) will also uninstall the existing version before installing themselves. User created data, such as 
projects, is not removed as part of this process and will remain intact. This ensures a clean starting 
state for Schedule Plus. 

Any paths stored as an access convenience by Schedule Plus, such those in the File > Open option, 
will not be updated by the migration. You will need to manually browse to the new location to select 
the specific file when using that function, which will update the stored path. 

Solidworks eDrawings Viewer 
The use of Solidworks eDrawings Viewer has been obsoleted and is no longer installed with or 

accessible from Schedule Plus. 

.NET Framework 4.8.1 
Previously, parts of Schedule Plus require the .NET Framework 4 to run. Now, they require .NET 

Framework 4.8.1 or compatible to run. 
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Previously, the .NET Framework 4 Runtime was shipped with and installed as part of Schedule Plus. 

As of this release, the .NET Framework Runtime is no longer shipped or installed as part of the 

Schedule Plus installation. If you do not have it or a compatible version already installed, you will 

need to download and install it separately for elements of Schedule Plus to operate normally. 

The installer will alert you if you do not have a compatible version of the runtime installed already. 

Microsoft SQL Server 
Previously, a version of Microsoft SQL Server Express was shipped with and installed by Schedule 

Plus as a convenience for enabling the database recording and reporting features. 

As of this release, Microsoft SQL Server Express is no longer shipped or installed as part of the 

Schedule Plus installation. 

If you wish to use the database reporting features of Schedule Plus, it is recommended that you 

consult with a database professional for more information on how to obtain, install, configure, 

secure, and connect to a Microsoft SQL Server instance to make use of the database reporting 

features of Schedule Plus. 

    If you already have the version of Microsoft SQL Server Express that was previously shipped with 

Schedule Plus, and are using it, then it will continue to operate after installation of this version of 

Schedule Plus. 

    With the migration of the Schedule Plus projects, Microsoft SQL Server cannot access files stored 

in the Documents folder. Any databases stored in your project folders will need to be moved to a 

different location and reattached to Microsoft SQL Server using a tool like SQL Server Management 

Studio. 

Security Enhancements 
This release includes other improvements that enhance the overall security of Schedule Plus. 

Support for Latest C-Gate 3 
This release adds support for connecting to version 3.7.0 of C-Gate 3. 

Other Fixes 
None. 
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Schedule Plus 5.10.0 

Released 
September 2025 
 

What’s New 

Image Editor Modifications (BREAKING CHANGE) 
This release modifies the behaviour of the Tools > Open Image Editor option. Now, when you invoke 

this option, Schedule Plus will ask the operating system to open the default image editing application 

it has configured. If no default editor is configured in the operating system or an error occurs while 

starting the default editor, then a message will be displayed informing you of this. 

As a result of this change, the Image Editor Path option in the Program Options has also been 

removed. 

These changes have been made to improve the security of Schedule Plus. 

User Details Dialog Modifications 
This release modifies the behaviour of the Access Level field in the User Details dialog. Now, the 

levels available to select for the new user in this field will not allow you to select a level higher than 

your own. 

This change has been made to improve the security of Schedule Plus. 

Security Enhancements 
This release includes other improvements that enhance the overall security of Schedule Plus. 

Help File Updates 
This release includes a new topic with cybersecurity recommendations to help you improve the 

security of Schedule Plus. This topic can be found under Introduction > Important Information > 

Cybersecurity in the Main help file. 

Support for Latest C-Gate 3 
This release adds support for connecting to version 3.6.0 of C-Gate 3. 

Other Fixes 
None. 
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Schedule Plus 5.9.0 

Released 
June 2025 
 

What’s New 

Support for Latest C-Gate 3 
This release adds support for connecting to version 3.5.0 of C-Gate 3. 

Other Fixes 
None. 
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Schedule Plus 5.8.0 

Released 
February 2025 
 

What’s New 

Support for Latest C-Gate 3 
This release adds support for connecting to version 3.4.1 of C-Gate 3. 

Other Fixes 
None. 
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Schedule Plus 5.7.0 

Released 
October 2024 
 

What’s New 

Support for Latest C-Gate 3 
This release adds support for connecting to version 3.4.0 of C-Gate 3. 

Other Fixes 
None. 
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Schedule Plus 5.6.0 

Released 
August 2024 
 

What’s New 

Support for Latest C-Gate 3 
This release adds support for connecting to version 3.3.4 of C-Gate 3. 

Other Fixes 
None. 
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Schedule Plus 5.5.0 

Released 
July 2024 
 

What’s New 

Support for Latest C-Gate 3 
This release adds support for connecting to version 3.3.3 of C-Gate 3. 

Other Fixes 
None. 
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Schedule Plus 5.4.0 

Released 
May 2024 
 

What’s New 

Support for Latest C-Gate 3 
This release adds support for connecting to version 3.3.2 of C-Gate 3. 

Other Fixes 
None. 
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Schedule Plus 5.3.0 

Released 
April 2024 
 

What’s New 

Support for Latest C-Gate 3 
This release adds support for connecting to version 3.3.1 of C-Gate 3. 

Other Fixes 
None. 
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Schedule Plus 5.2.0 

Released 
April 2024 
 

What’s New 

Support for Latest C-Gate 3 
This release adds support for connecting to version 3.3.0 of C-Gate 3. 

Other Fixes 
None. 
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Schedule Plus 5.1.0 

Released 
February 2024 
 

What’s New 

Introduction of C-Gate 3 (BREAKING CHANGE) 
This release requires a new version of C-Gate that is incompatible with older versions of C-Gate 

(2.11.11 and below) and Schedule Plus (5.0 and below). 

    C-Gate 3 cannot co-exist on the same machine as C-Gate 2. 

This new version of C-Gate is required to allow configuration of new C-Bus digital dimmers and DALI 

devices (via a C-Bus DALI-2 Gateway) using SpaceLogic C-Bus Commission. This release of Schedule 

Plus allows for C-Gate 3 compatibility. 

    Schedule Plus 5.1 (and above) cannot be used with C-Gate 2 (and below). 

C-Gate Runtime 
This release now sees Schedule Plus automatically start and stop C-Gate locally when it is started 

and stopped. This is regardless of whether C-Gate is running in service or console mode locally. 

If Schedule Plus is configured to connect to a remote instance of C-Gate on a different computer, 

then it does not attempt to start or stop C-Gate on the other computer. When connected to a local 

instance of C-Gate on the same computer then Schedule Plus will not attempt to stop C-Gate if there 

are other clients such as C-Bus Toolkit connected to it. 

Automatic shutdown of C-Gate can be controlled through the Options > Program Options > C-Gate > 

Shut Down Behaviour setting: 
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New Project Format 
This release adds support for the new project file format used by C-Gate 3.2.0. Only projects that 

have been successfully converted can be opened. 

C-Gate 3.2.0 
This release requires C-Gate 3.2.0 or later to operate. 

    Rolling back to Schedule Plus 5.0 (and below) on a PC that has C-Bus Toolkit 1.17 (and above), 
and / or SpaceLogic C-Bus Commission 2 (or above), is not supported without the complete removal 
of C-Bus Toolkit 1.17, SpaceLogic C-Bus Commission 2 and C-Gate 3.2 first. Additionally, C-Bus 
projects created or updated from C-Bus Toolkit 1.17 and SpaceLogic C-Bus Commission 2 cannot be 
converted back to previous versions. 

C-Gate Version Checking 
This release implements more stringent version checking of the C-Gate instance to which it is 

connected. A message is displayed if the version of C-Gate detected is not compatible with this 

version of Schedule Plus. 
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The most likely scenario where this will occur is when C-Gate has been updated as part of a 
SpaceLogic C-Bus Commission or C-Bus Toolkit upgrade, but Schedule Plus has not been upgraded at 
the same time. In this situation the Schedule Plus version will need to be updated to be compatible 
with the version of C-Gate that is installed. 
 

Other Fixes 

• Fixed an issue with hints displaying in the status bar of the main window when in the logic 

editor. 

• Fixed an issue with the DALI line mapping being reset to line A when line B is selected and saved. 
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Schedule Plus 5.0.3 

Released 
April 2018 
 

What’s New 

Removal of License Keys 
This release removes the need for hardware license keys (dongles) during the operation of Schedule 

Plus. It is still required that a license appropriate to the intended use (number of networks) be 

purchased, but from this version onwards the hardware license is no longer required to be present 

during operation. Versions prior to this one still requires the license to be present, and future 

versions may require the hardware license to be transferred to have continued operation of 

Schedule Plus. 

 

Adjustments to Network Status Indicators 
This release modifies how the network status is represented in the status bar. Previously this was a 

text-based description that included a multi-coloured bar representation. Under normal 

circumstances this text could be hard to read and in certain conditions the information in it could be 

incorrect. The following picture illustrates the new layout of the indicators. 

 

From left to right the indicators are: 

• Online (green) 

• Offline / Error (red) 

• Syncing (orange) 

• Operational (yellow) 

• Not in Use (grey) 

These indicators are only shown when Schedule Plus is connected to C-Bus. If you hover the mouse 

above any of the segments in the status bar, a tool tip will be displayed that indicates the meaning of 

that segment. It should be noted that there is no special relationship between the numbers shown. 

For example, if you add them together they won’t necessarily equal the total number of networks in 

the project. Any network whose Use in Project flag is not set will be included in the Not in Use 

status, regardless of its actual state. 

 

Adjustments to Network Status Detection 
This release improves how Schedule Plus detects when networks are opened or closed by external 

means (e.g. through Toolkit, the C-Gate console, etc.). Previously, Schedule Plus could detect an 

external closure of a network and adjust the status accordingly, but when a network was opened 

externally it did not detect this scenario and the network remained in the offline state. Schedule Plus 

now receives notifications from C-Gate when the network interface changes state to open, puts the 

network into the sync state and issues a command to C-Gate to force a sync of that network. This 
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helps to bring the network back online within Schedule Plus as efficiently as possible. A side effect of 

this change is that it improves the interoperability between Schedule Plus and Toolkit. 

 

Adjustments to Logging 
Elements of the logging functionality have been improved in this release. 
 
The Event Log window has been refactored to make it easier to review the log entries and the 
options have been consolidated onto one tab now, which should make it easier to understand the 
interactions between them. 
 
Logging previously occurred within the main program thread, which meant that log entries may not 
have been recorded under certain situations. In this release, the logging functions now run in a 
separate program thread, which should improve this situation. 
 
Log files are now named using the following convention: 
 
SchedulePlusyyyymmdd-n.txt 
 
where, 

• yyyy is the current year 

• mm is the current month 

• dd is the current day 

• n is the file number for the current day 
 
The file number starts at 1 for the current day and, if the Limit File Size option is enabled, will 
increment each time a file exceeds 10MB for the current day and a new file will be started. A new 
log file will automatically be started when the date rolls over. 
 

Other Fixes 

• SP-3752 – Communication issues trying to open a closed CNI network. 

• SP-3756 – Incomplete opening and synchronisation of a closed C-Bus network. 

• SP-3832 – Show C-Gate Messages logging option not persisted between sessions. 

• SP-3833 – Page names containing \ and / cause HTML compilation to fail. 

• SP-3835 – Fix webcam refresh rate being ignored. 

• SP-3836 – Improve locking for objects accessed concurrently by Schedule Plus and web services. 

• SP-3837 – Fix access violation in Scene Editor window. 
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Schedule Plus 5.0.2 

Released 
June 2017 
 

What’s New 

Image Loading 
This release modifies how images for the project are loaded. Previously all images were loaded in to 
memory when the project was opened. For compressed image formats, such as PNG, which are 
decompressed when loaded, this caused a large increase in the memory used by Schedule Plus. 
Images are not loaded on a just in time basis, but once loaded they remain in memory until the 
project is closed. This improves Schedule Plus’s ability to open projects that contain many high-
resolution images. 
 
NOTE: Projects that contain many high-resolution images will still experience issues when switching 
to operation mode if the Web Server function is enabled. You can avoid these issues by disabling the 
Web Server for the project in the Project Details window.  
 

Other Fixes 

• SP-3830 – Fixed a crash when opening a project with many high-resolution images. 
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Schedule Plus 5.0.1 

Released 
January 2017 
 

What’s New 

Dongles 
This release removes the requirement for installer dongles to be version 5. This means that 
customers who have previously purchased an Installer dongle for use with earlier versions will now 
be able to use them with version 5. 
 

Other Fixes 

• SP-3827 – The All Profiles group does not include more than 16 profiles, regardless of how many 

are created. 
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Schedule Plus 5.0.0 

Released 
March 2016 
 

What’s New 

Web Server 
This release introduces a web server, which can optionally be enabled for a project to allow control 

of it via a web browser. The web server supports both unsecured HTTP and secured HTTPS 

connections. Access to the web server is by profiles created within the project. With a few 

exceptions, most Schedule Plus functionality and components can be controlled via the web server. 

Multiple clients connected via the web server will be synchronized, that is, if a group is turned on in 

one client then all the other clients will reflect that change. The web server currently supports up to 

10 concurrent clients. It has been tested with all popular browsers (Chrome, Internet Explorer, 

Firefox, Safari, and Opera). 

 

Database Logging 
This release introduces the ability to log C-Bus events to a Microsoft SQL Server database (2008 R2 

or above). The information recorded includes C-Bus project data (networks, applications, groups, 

levels), C-Bus application data (lighting, measurement, error reporting, HVAC, irrigation) and the 

Schedule Plus log. The database can also be periodically backed up and a snapshot of the Schedule 

Plus project recorded in the database. The installer provides an optional component that will install 

Microsoft SQL Server 2008 R2 Express. If you elect not to install this component, then the database 

functionality may still be used if you already have another instance of SQL Server installed. 

 

Database Reporting 
On top of the Database Logging functionality, this release introduces the ability to report on the 

information recorded in the database using Crystal Reports. This functionality is supported by a 

dedicated reporting window and new special functions for generating reports. 

 

Drawing File Support 
This release introduces the ability to incorporate common drawing formats such as DWG and DXF. 

This feature is provided by the eDrawings viewer from SolidWorks. This is an optional component 

when installing Schedule Plus 5, meaning that this functionality will not be available if the viewer is 

not installed. 

 

Other Fixes 

• SP-63 – Crash when user tries to load the projects from C-Gate and no IP address has been 

entered 

• SP-128 – Content of HTML component not visible in operation mode 

• SP-3113 – Public holiday templates updated to cover 2015-2020 

• SP-3362 – Name field covering buttons in Add Irrigation Program window 
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• SP-3363 – Irrigation schedule not appearing when created 

• SP-3364 – Add irrigation schedule wizard opening on wrong step 

• SP-3407 – Memory leaks 

• SP-3414 – Network status percentage displayed incorrectly when networks are offline 

• SP-3443 – Added support for the C-Gate SESSION_ID TAG command 

• SP-3565 – Error when entering access control pin after restoring project 

• SP-3573 – Issue with appearance of version number on splash screen 

• SP-3578 – General memory leaks 

• SP-3579 – Web client memory leaks 

• SP-3582 – Access violation with graph component 

• SP-3585 – Use native OS look and feel 

• SP-3589 – Select normal dongle over installer licence 

• SP-3593 – Access violation when using web camera component 

• SP-3594 – Memory leaks in web server 

• SP-3606 – Licence check period not accurate 

• SP-3625 – Maps Used field displays incorrect information in DALI window 

• SP-3628 – Field layout in DALI tab of Project Details window adjusted for clarity 

• SP-3630 – Increased DALI mapping limit from 512 to 1024 

• SP-3631 – DALI UDP port opened exclusively 

• SP-3678 – Toolkit project file prefixed with “CBus-“ when archiving 

• SP-3780 – Access violation when opening an archive 

• SP-3781 – Access violation related to profiles when loading a project 

 
 
 
 


